N
Number6
Nov 30, 2013

Netflix not working on Nexus 7 tablet?

Just in time for the long Thanksgiving weekend, my Nexus 7 stopped working with Netflix. I can’t get past login and just get a message along the lines of “sorry, can’t connect to Netflix.” Ok, but on the same network I have at least 3 other devices that can connect just fine. I can literally set down the Nexus 7 tablet, and pull it up on my laptop instantly. Any suggestions?

jimlynch
12/05/2013
You might also want to check the Netflix Help Center:

https://help.netflix.com/help
w
wstark
12/02/2013

Go into settings, then apps. Go to the Netflix app (in settings, not back out to the app), clear data, shutdown and restart your tablet. Try netflix again (you will have to re-enter your login info). If that doesn’t work uninstall and reinstall Netflix, as suggested in Christopher’s post. If that doesn’t work, I guess the next thing would be to call Netflix. In my experience, they actually have pretty good customer service.

J
Jason Lilli
12/03/2013

Honestly, nothing listed in the other response will work at this time. First off, that answer was referrencing issues in 4.3; most of those have been addressed. Your issue, probably just like mine is on a Nexus 7 running 4.4. If you are indeed getting the same error message I did, it would be the (-9) error code. I've been working with Netflix's research team to identify the issue, which is not solved as it's only happening to a number of users. They are aware of the issue and have already given me a free month of Netflix for calling lol. The only thing that works for now is to sideload the 3.0 Netflix Software and make sure you turn off the "auto update" feature for the app in the play store. If you don't, it will update it to 3.02 and you will have to uninstall and do it over again. Just keep the 3.0 apk on your device and you shouldn't have an issue until they get this ironed out. Let me know if you need any help downloading or installing the apk. You can find it on Androidpolice:

 

http://www.androidpolice.com/2013/10/16/netflix-v3-0-for-android-begins-...

 

Or just google search for the 3.0 apk.  Hope this helps.

C
Christopher Nerney
12/02/2013

This problem is the topic of a long thread in the Google Products Forum. There are several suggestions in the thread, from wiping the Nexus 7's cache partition to simply uninstalling and reinstalling Netflix for Android. Here's one comprehensive suggestion:

 

"There are at least 2 distinct problems that have plagued the Nexus 7 and NETFLIX since the release of the new Nexus 7. The first problem was resolved with an update of the NETFLIX application for ANDROID. The second has not been addressed yet. The current problem manifests itself as a "network error" and "cannot connect to your netflix account". I was able to resolve this problem by "uninstalling" the NETFLIX ANDROID application, downloading, and reinstalling from the GOOGLE PLAY STORE. You should be on ANDROID Version 4.3 Build Number JSS15J by today, 8/26/2013. You should also have installed the NETFLIX app dated 8/7/2013 with the fixes for ANDROID 4.3 and the "Nexus 7 HD" as they call it. Your Chromecast application should be updated to 8/15/2013. Your Chromecast itself should be on Build 12940. Remember, each device must be powered on and connected to your wireless network to receive the push updates from Google."

Answer this