r
ryland
Apr 04, 2013

Metro Apps crash right after I launch them. What can I do?

D
David Dutton
01/11/2014

First of Refresh the PC should be the Last, and I mean VERY last resort you do. A windows installating has to be PRETTY darn corrupted to even suggest this

 

MS has had MASSIVE issues with the metro apps since windows 8 and especially 8.1... even their tool can't fix it most of the time

 

Im plagued with this issue, and I've tried every solution to no avail.. REFRESHING IS NOT AN OPTION... Sure I could keep my "data" files, but that's just user folder stuff... I'd have to reinstall over 100 games , programs, applications.. no way

 

it was working perfectly fine before 8.1... metro DEAD after 8.1

 

I CAN run the store just fine, but I can't not install, repair, etc.

 

I've never tried setting every folder and file to allow EVERYONE and ALL APPLICATION PACKAGES FULL control...

 

no dice..

 

It seems there's a file that has a digital signature borked and nothing seeems to fix it:

 

Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF0, Package could
not be opened.
error 0x80070241: Reading manifest from location:
C:\Windows\WinStore\AppxManifest.xml failed with error: Windows cannot verify
the digital signature for this file. A recent hardware or software change
might have installed a file that is signed incorrectly or damaged, or that
might be malicious software from an unknown source.
.
NOTE: For additional information, look for [ActivityId]
8734b549-0eb9-0004-e5b5-3487b90ecf01 in the Event Log or use the command line
Get-AppxLog -ActivityID 8734b549-0eb9-0004-e5b5-3487b90ecf01
At line:1 char:1
+ Add-AppxPackage -DisableDevelopmentMode -Register
$Env:SystemRoot\WinStore\AppxM ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~~~
    + CategoryInfo          : OpenError: (C:\Windows\WinStore\AppxManifest.xml
   :String) [Add-AppxPackage], FileNotFoundException
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageMa
   nager.Commands.AddAppxPackageCommand

 

I think if someone had a fix for THAT.. that would solve my issue

J
Jason Johnson
11/25/2013

I fixed this probleb by setting my gaming options on the AMD catalyst to default. I am almost posiitive  it was some antialaising setting. I was lucking this happen twice and I retraced my steps before the issue occured.

S
Stephen Sykes
10/31/2013

I tried everything, searched google for days, and this is what finally worked for me after my Metro apps wouldn't start after upgrading to 8.1...

 

Re-register the Store App

  • Run cmd as administrator
  • paste "powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml" without the quotes
  • Hit Enter
  •  

    No restart required. Good Luck. ;)

    A
    Alberto Zanardo
    07/08/2013

    I resolved this and al lot of other Windows 8 problems doing this:

    -Open CMD as Administrator-Type "sfc /scannow" (without quotes)-Press Enter and wait (10/30 minutes)-Restart your pc and everythings should be ok I hope this fix your problems ;)
    C
    Christopher Nerney
    04/05/2013

    Enough people have had your problem that Microsoft has some pages devoted to it in its Community Answers support site. Some people on this thread say the problem is with the NVIDIA graphics card. A forum moderator suggests this process:

     

    Check the following:

     

    • You need at least 1024X768 resolution for Metro apps to work
    • Confirm if the issue reproduces with all user accounts. Metro apps aren’t supported if you are running with a built-in administrator account (happens mostly when upgrading)
    • Check if UAC (User Account Control) is enabled. UAC must be enabled for Metro apps to work. It’s possible that a third party application may have disabled the User Account Control, in which case the apps won’t work. To check, simply type UAC from the home screen and it will appear on the Settings search result
    • Try using a local account instead of a Microsoft Account (Live ID)
    • Refresh your PCHere's another thread started by a user whose Metro Apps started crashing after he upgraded to Windows 8. And here's one with instructions for a troubleshooter developed by Microsoft for computers running on Windows 8 that are experiencing apps problems.
    Answer this