Jan 18, 2016

How can I fix Belkin F9K1103V1 wireless router that stopped working--solid amber light?

I checked with my cable internet provider and the cable modem is working properly..but randomly, my wireless router wont work at all. All it shows is a solid amber light.

I tried unplugging the router and modem (both the power supplies and cables). I waited several minutes and then plugged in the cable and power supple to the modem. Once it was up and running (all lights are green or blue--as they should be for normal and proper function), I plugged in the power supply to the router. The router still was only solid amber.

I then tried to unplug the modem, and pressed the reset button on router for 1 min, then waited 15 seconds and unplugged router. I plugged in modem and waited for all lights to come on and then plugged in the router. again, only solid amber light on router.

I tried to open the belkin setup on my computer but it wouldn't come up at all (almost like there was no software saved?) so I uninstalled.

I was going to use the disc to reinstall, but cannot locate the disc.

In layman's terms, what should I do next? I am not completely computer illiterate, but I am also not extremely tech savvy.
Try resetting the router to factory defaults. Hold down the red reset button for five seconds. When the router light stops blinking and is solid, it will be reset. Note that this will reset any settings including wifi password you might have setup to the initial state.
I also tried to locate and download the software from belkin support. When I try to open the downloaded file (.run file) it asks what application I was to use to open it....??? and I'm not sure what to use or if this file is even what I need?
Answer this