Mar 23, 2015

Why is my Belkin range extender not connecting to my router ?

i have N600 Dual-Band Wi-Fi Range Extender and it is not connecting to router . please help
I had belkin range extender which was working fine for many years. One day it stopped working.Tried everything after reading many article on internet.I thought its dead, but at last i got some steps which make my problem fix. You may visit for steps here
I've tryed twelve times.
Please make sure you have used the correct username and password for setting up your netgear range extender. if your netgear range extender is still not working then you need to try to setup it after resetting.
I have N600 dual-band wi-fi range extender but cannot connect. Does it function with windows 10 and if so what do I have to do to get up and running
I have same problem. It initially worked - briefly. Then stopped. Then we got replacement router, I pressed 'reset' for 10 seconds to restore factory settings, and the belkin extender does not even show up in list of available wireless networks most of time. If it does show on the list, all I get is a 'timed out' message.
range extender is a plug-and-play device after setup. First connect your computer with range extender with a cable then open the default gateway IP in your browser and now put your router name and password and you will get Belkin range extender extended network as you want
i still cant get it to work its says limited no intenet
first restart your both devices click the Restore Factory Defaults button and follow the on screen instructions.
restart your router and range extender and type to setup the range extender with correct password. then you will be successfully connected.
Launch a web browser. Enter "belkin.range" in the Address bar then press [Enter]

2.Under Utilities, click Restore Factory Defaults.

3. Click the Restore Factory Defaults button and follow the on screen instructions.

i think just hard reset the range extender and connect it to computer with using Ethernet cable . and setup it as manual says . i hope this will help . thanks
Looks like you have two answer already, but here's a link to the official Belkin support site in case you need it:
Usually this problem comes, when your range extender is not properly updated or reset. so you need to press and hold the reset button on your extender for 15 minutes and reconfigure it. now it will start working fine.
I think this problem usually comes when your extender is not properly reseted or updated. so in this situation you need to reset your range extender and reconfigure it . it will start working fine.
Answer this