Mar 18, 2015

How to fix Chromebook dropping WiFi connection upon wake?

My HP Chromebook 14 has been having a network connectivity issue lately. Sometimes, but not always, when it wakes from sleep I will get an error message saying I’m not connected to the internet when I try to load a site. My WiFi status still shows that I am connected and have a good signal. I can run connectivity diagnostics, and everything checks out showing that I am connected, but it still behaves as if I am not. I have to manually go it, disconnect from the access point, then reconnect to that same access point for it to work again. Any ideas?
this problem usually comes, whenever your wireless driver is not properly updated. so in this situation you need to go ahead and update your drivers. it will start working fine.
YOU need to update your wireless driver . then it will start working fine.
oh peter... if only chromebooks had wireless drivers :)
First of all you should try to change the wireless signal and wireless security type on your wifi. now try to connect your chromebook.

If it is still not working, then you need to drivers properly updated . so you need to go update your wireless drivers. you can also uninstall the driver and install it back in .
i think this can be fixed easely.update the wireless firmware and make sure you have the proper internet connetion
if it does not work just do a clean restore to last known good configuration .i am sure this will help .thanks
I’ve had this problem intermittently as well, also with an HP Chromebook. I haven’t been able to determine the cause, but a likely suspect is one of your plug-ins/extensions. Try disabling them to see if this helps.

There was a long discussion about this on the Chromebook product forums. There was a lot of “blame the router” being played, but I’m not buying that. Just to be sure, make sure your router firmware is up to date and reboot it, but I’m doubtful that will help.

One suggestion that might work is to go into SETTINGS>ADVANCED>PRIVACY and check the box in the privacy section to leave WiFi on during sleep. I just realized you could do this and am trying it, but since the problem is intermittent, I'm not sure if it helped or not.
Oh, link to that discussion:!topic/chromebook-central/EXEIEUPK64w
Answer this