z
May 01, 2014

How to resolve limited connectivity error on Windows 7 laptop?

When connecting my personal laptop, which is running Windows 7, to my office’s wireless network I keep getting a “limited connectivity error”. I can connect fine at home. What can I do to resolve this?

Best answer
12/07/2014
guys I found the solution myself
simply go to :
Control Panel\Network and Internet\Network and Sharing Center
from the left pane choose:
manage wireless networks
then delete ur network connection
after that choose adapter properties

under: this connection uses the following items :
uncheck : AVG network filter driver
and retry reconnecting to network it will work immediately even without restarting system
05/01/2016
THANKS! SheryGirl1991 from two years ago! I have been fighting this for 48 hours. I was trying to remove traces of Cisco VPN and played with the registry without a backup... I lost wired and wireless connectivity, and nothing I googled worked. Because of her post I found a "Lightweight DNE filter" on each adapter, once I clicked them off and enabled each THEY WORKED. Why these got into the adapter or why all of a sudden they caused grief is unknown but if your problem relates to removing VPN manually and you lose connectivity try removing anything with teh word "filer" from your adapter properties.

Love and hugs!!!!
Bob (Canada)
03/28/2016
I noticed this problem with my fresh install W7 computer. I finally named a computer administrator and put in a password and this solved the [problem for me. Apparently the computer software was designed so that it would not let me have wireless access without it
02/04/2016
I have a simple solution and it works: You can restart your router from the router button or you can use this method if the router is away from you.

type: 192.168.1.1 in the address bar of browser then type username: admin and Pass: admin

login and click on the management in the left side then click reboot and again click reboot appear in the middle of the window screen.
11/18/2015
guys do a simple system restore to a restore point when your wifi had no probem. Hope this will for sure fix your problem

NOTE: during system restore files and other installed programs might be lost..BE CAREFULL.
09/26/2015
reboot
05/12/2015
1. Run cmd as administrator
2. Input netsh winsock reset, then press enter
3. Restart your computer

Read more: http://update-windows-drivers.blogspot.com/2015/03/solutions-to-computer-cannot-connect-to-wifi.html
05/14/2015
Fixed it for me. Thanks so much!
11/15/2015
thanks a lot it really helped !! :)
1 week ago
Excellent, It's works for me as well , Thank you
03/16/2015
I had an issue where only my windows 7 enterprise laptop would not connect to Wifi. It would disable the router and no other devices could connect. It would show limited access in the laptop. But wired connection to the router would work to connect to internet.

I tried 100 things but the one thing which worked was to upgrade the firmware of the router. I have TP-link WR841N router. I went to their website got the update of the same version of firmware. After running the setup and restarting the router, modem and laptop now it looks like it is working.
10/22/2015
Fantastic - SO helpful!
Best answer
12/07/2014
guys I found the solution myself
simply go to :
Control Panel\Network and Internet\Network and Sharing Center
from the left pane choose:
manage wireless networks
then delete ur network connection
after that choose adapter properties

under: this connection uses the following items :
uncheck : AVG network filter driver
and retry reconnecting to network it will work immediately even without restarting system
02/04/2015
Thx u thx u thx u so much i wish i could pay u
03/30/2015
Thnk u so much.. I ws jst tired of ths problem :)
05/11/2015
Thank u very much for such a smart solution.
06/22/2015
Not working for me..
07/17/2015
Thank you very much its really work
08/17/2015
Thanks for the fix.

I would like add a point here. I was having the same problem. I did the same but I had an entry of hotspot shield (which i removed recently) instead AVG filter. This was creating problem. So I unchecked it and it worked.

Thank you.
10/17/2015
Thanks very much I was thinking of formating the OS I am a network administrator at Nvidia but I myself didn't think of this option the very much u made my day love you love, and if you guys don't find avg network filter find the name of a 3rd party firewall which may have been installed with Antivirus or Internet Security or the name of a VPN that you have Installed :D
01/07/2016
Thnku so much i even called network engineer but that dummy told me that ur wifi drivers are not updated. Solution of a problem which whole Airtel network team couldn't resolve u solved it within few steps. God bless
01/25/2016
I went under those settings, and it wasn't AVG, but a VPN program that was the issue. Fixed! Thanks a million, I was pulling my hair out trying to get this to work! :)
02/09/2016
THANK U SO MUCH FOR THE SOLUTION....IT WAS VERY BORING AND TIRESOME FINDING THE SOLUTION FOR THIS PROBLEM.
U MADE MY DAY...THANK U AGAIN
02/27/2016
tanq ....i was trying it from yesterday .....got it now :)
03/15/2016
Thanks shery and afreen for great solution
b
05/23/2014

Make your sure that whether your office wifi connection requires ip address or not ? You can check this by following steps:

 

1) open control panel > Network and internet > network and sharing center > change adapter settings(topright) >  right click on Wireless network connection > properties > double click on IPV4 

 

You can either put the IP address as provided by your office IPS or you may remove it , in case it doesn't require.

 

Hope it works !! :)

10/07/2015
Thanks it works!!!!
D
05/03/2014

I suggest to perform these steps to troubleshoot the issue:

1) Temporary disable firewall and antivirus on your PC

2) Reinstall or update your NIC driver.

3) Disable IPV6

4) Check the NETBIOS of TCP/IP is enable or not

5) Furthermore, you can go to computer management\device manger, select Network adapters and press view\show hidden devices, remove all unnecessary network drivers.

c
05/02/2014

I would check a few things. Make sure your laptop’s wireless network card is set to automatically receive an IP address. If not, clear your current IP and DNS settings and let them be set automatically. Also make sure that the latest drivers for your wireless network card are installed. 

 

If that doesn’t work, check to make sure that you wireless card supports the transmit mode used by the router (802.11b, 802.11c, 802.11n). If it doesn’t, the wireless mode on the router would need to be changed. Also, check to see if MAC address filtering is enabled on the router and add your laptop if necessary. Other than that, about all you can do is make sure the firmware is up to date on the router. There is a chance that your laptop’s wireless card in incompatible with the router. 

Answer this